We are currently experiencing technical difficulties. Access to Provation Apex may be impacted at this time.
Incident Report for Provation
Resolved
This incident has been resolved.
Posted Jun 17, 2019 - 09:45 CDT
Monitoring
Apex service has been restored. Please refresh your browser if you already have Apex open.
Posted Jun 17, 2019 - 09:37 CDT
Investigating
We are currently investigating the issue.
Posted Jun 17, 2019 - 09:22 CDT
This incident affected: Provation Apex.