Provation iPro is currently experiencing technical difficulties
Incident Report for Provation
Resolved
Provation iPro has fully recovered. We apologize for the inconvenience.
Posted Nov 27, 2023 - 09:09 CST
Identified
Provation iPro is currently experiencing an outage and may not be reached. Investigation is underway. New information will be posted here as it becomes available.
Posted Nov 27, 2023 - 09:08 CST
Investigating
We are actively investigating an incident with iPro.
Posted Nov 27, 2023 - 08:18 CST
This incident affected: iPro-anesthesia-instance-6272.