Provation Apex is currently experiencing technical difficulties

Incident Report for Provation

Resolved

This incident has been resolved.
Posted Feb 24, 2026 - 13:59 CST

Investigating

We are actively investigating an incident with Apex printing and previewing a note.
Posted Feb 24, 2026 - 12:35 CST
This incident affected: Provation Apex.