Provation SurgicalValet is currently experiencing technical difficulties
Incident Report for Provation
Postmortem

On June 15th, 8:35 AM CST, Surgical Valet & Quality encountered an incident with the web application certificate, causing downtime to the system. Certificates were updated and access to the API was restored. All systems were restored by 9:51 AM CST.

Posted Jul 05, 2023 - 08:24 CDT

Resolved
We are actively working to investigate the issue. Additional information will be posted on this page as it becomes available.
Posted Jun 15, 2023 - 19:30 CDT